Engine starts/revs but no idle
11-15-2021, 01:58 PM
Post: #11
Engine starts/revs but no idle
Can you check your fuel pressure. Should be around 38 PSI. Pull off the return hose on the fuel regulator and verify flow, or swap in a known good regulator. You could also pull fuel manifold, and check if the injectors are leaking. But I would think the odds that they would all leak is pretty low, unless you have extremely high fuel pressure. Dave W
Find all posts by this user
11-15-2021, 07:06 PM
Post: #12
Engine starts/revs but no idle
No leaks when checked, I swapped the fuel pressure regulator from the running loaner engine and no change. Disconnected the return line and confirmed fuel flow. Injectors have brand new o-rings and insulators. I have a tomei adjustable regulator with pressure gauge I can try tomorrow.
Find all posts by this user
11-16-2021, 07:41 AM (This post was last modified: 11-16-2021 08:55 AM by GenkiMotors.)
Post: #13
Engine starts/revs but no idle
Put the fuel pressure gauge on and bridged the connector for the pump. Fuel pressure was right at 38psi... I'm absolutely stumped...

*EDIT* I did another compression test (on a moderately cold engine), this time the cylinders were #1: 1450kpa (210psi), #2: 1450kpa (210psi), #3: 1470kpa (213psi), #4: 1430kpa (207psi) so the compression is lower than previously stated.

Just for reference, before I rebuilt the engine, the compression was #1: 1400kpa (203psi), #2: 1000kpa (145psi), #3: 1350kpa (195psi), #4: 1450kpa (210psi), when I took the engine apart, the ringlands in pistons 2&3 were cracked, but the rings were not cracked which is why I think it was able to make some compression.

Thanks again you guys for the responses! I really appreciate it Smile
Find all posts by this user
11-16-2021, 02:30 PM
Post: #14
Engine starts/revs but no idle
Check the vacuum hose going to the fuel reg. Do you see a change in fuel pressure. When disconnected, should be at 38 PSI and at idle it should be about 29 PSI.
Double check the cold start injector for leakage, when the engine is up to temp.
Dave W
Find all posts by this user
11-17-2021, 08:44 AM
Post: #15
Engine starts/revs but no idle
Every vacuum hose has been replaced and checked. Fuel pressures are where they should be. I took the cold start injector out and checked, no leaks.
I tried starting it with some vacuum hoses disconnected and it kind of idled longer letting more air in.
Find all posts by this user
11-17-2021, 10:52 AM (This post was last modified: 11-17-2021 11:15 AM by Ivan141.)
Post: #16
Engine starts/revs but no idle
I'm assuming you are using the engine diagnostics manual we link to on the aeu86 home page, that way you can systematically rule out the most likely causes.
And it might sound silly, but put up some pictures of your engine install, with some special attention to ground points. I know we have a few people here who can spot something off with one look.

Also have a look at these (in case you havent already):
https://www.club4ag.com/forums/viewtopic.php?t=17881
https://www.club4ag.com/forums/viewtopic.php?t=11079

FABRICA MI DIEM, PVNC!
Visit this user's website Find all posts by this user
11-18-2021, 10:31 AM
Post: #17
Engine starts/revs but no idle
Try removing the SAFC
Cusco MFE doesn't need it with those cams anyway.

An analogue brain in a digital World
Find all posts by this user
11-20-2021, 04:12 AM
Post: #18
Engine starts/revs but no idle
I'll take some pics and upload them soon. Taking a few days off from the car to focus on work and so I can come back to it with a clear head
Find all posts by this user


Possibly Related Threads...
Thread Author Replies Views Last Post
  exhaust odor/idle MOT issue Ryo 7 4,444 07-15-2019 09:17 AM
Last Post: jondee86
  AE86 4age engine not starts crank ok backfires to air intake Ryo 18 9,945 08-16-2018 01:36 AM
Last Post: Bean
  20v silvertop idle issue AlexFourTwenty 3 3,082 12-24-2017 03:27 AM
Last Post: AlexFourTwenty
  Silver top low idle AlexFourTwenty 7 5,636 10-16-2017 10:22 PM
Last Post: AlexFourTwenty
  Carb conversion but what is this and how ? Allexz 5 5,631 05-24-2016 08:48 AM
Last Post: Allexz

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | AEU86 | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication